import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^()\\n]*)\\(([^()\\n]*)\\)(.*)$";
final String string = "flow gavage(ZAB_B2_COCUM) BS\n\n"
+ "flowWithoutSpace (WitoutUnderscore) BS";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}