const regex = /^([^()\n]*)\(([^()\n]*)\)(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^()\\n]*)\\(([^()\\n]*)\\)(.*)$', 'gm')
const str = `flow gavage(ZAB_B2_COCUM) BS
flowWithoutSpace (WitoutUnderscore) BS`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);