package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$this->assertAttributeEquals\(([$\[\]|a-zA-Z1-9 ,]+), '([a-zAZ])([a-zAZ]+)', ([$1-9a-zA-Z\->]+)\);`)
var str = `$this->assertAttributeEquals($target, 'thevalue', $object);`
var substitution = "$this->assertEquals($1, $4->get\U$2\E$3());"
fmt.Println(re.ReplaceAllString(str, substitution))
}