re = /\$this->assertAttributeEquals\(([$\[\]|a-zA-Z1-9 ,]+), '([a-zAZ])([a-zAZ]+)', ([$1-9a-zA-Z\->]+)\);/m
str = '$this->assertAttributeEquals($target, \'thevalue\', $object);'
subst = '$this->assertEquals($1, $4->get\\U$2\\E$3());'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result