use strict;
my $str = '$this->assertAttributeEquals($target, \'thevalue\', $object);';
my $regex = qr/\$this->assertAttributeEquals\(([$\[\]|a-zA-Z1-9 ,]+), '([a-zAZ])([a-zAZ]+)', ([$1-9a-zA-Z\->]+)\);/mp;
my $subst = '$this->assertEquals($1, $4->get\\U$2\\E$3());';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";