import Foundation
let pattern = #"\$this->assertAttributeEquals\(([$\[\]|a-zA-Z1-9 ,]+), '([a-zAZ])([a-zAZ]+)', ([$1-9a-zA-Z\->]+)\);"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"$this->assertAttributeEquals($target, 'thevalue', $object);"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$this->assertEquals($1, $4->get\U$2\E$3());"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)