using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\()|(\))|(?:(\w+):)?(?:(\w+)|""([^""]+)""|\/([^\/]+)\/(g|m|i|x|s|u)?)";
string input = @"Hello (name:""New World"" OR name:""Old World"" OR name:/\w+ World/)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}