$re = '/(\()|(\))|(?:(\w+):)?(?:(\w+)|"([^"]+)"|\/([^\/]+)\/(g|m|i|x|s|u)?)/m';
$str = 'Hello (name:"New World" OR name:"Old World" OR name:/\\w+ World/)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);