re = /(\()|(\))|(?:(\w+):)?(?:(\w+)|"([^"]+)"|\/([^\/]+)\/(g|m|i|x|s|u)?)/m
str = 'Hello (name:"New World" OR name:"Old World" OR name:/\\w+ World/)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end