package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\()|(\))|(?:(\w+):)?(?:(\w+)|"([^"]+)"|\/([^\/]+)\/(g|m|i|x|s|u)?)`)
var str = `Hello (name:"New World" OR name:"Old World" OR name:/\w+ World/)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}