using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:class|className)=(?:[""']\W+\s*(?:\w+)\()?[""']([^'""]+)['""]";
string input = @"<div id=""content"" class=""container"">
<div style=""overflow:hidden;margin-top:30px"">
<div style=""width:300px;height:250px;float:left"">
<ins class=""adsbygoogle turbo"" style=""display:inline-block !important;width:300px;min-height:250px; display: none !important;"" data-ad-client=""ca-pub-1904398025977193"" data-ad-slot=""4723729075"" data-color-link=""2244BB"" qgdsrhu="" hidden=""></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
<img src=""http://static.teleman.pl/images/pixel.gif?show,753804,20160812"" alt="" width=""0"" height=""0"" hidden="" style=""display: none !important;"">
</div>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}