import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:class|className)=(?:[\"']\\W+\\s*(?:\\w+)\\()?[\"']([^'\"]+)['\"]";
final String string = "<div id=\"content\" class=\"container\">\n\n"
+ "<div style=\"overflow:hidden;margin-top:30px\">\n"
+ " <div style=\"width:300px;height:250px;float:left\">\n"
+ "<ins class=\"adsbygoogle turbo\" style=\"display:inline-block !important;width:300px;min-height:250px; display: none !important;\" data-ad-client=\"ca-pub-1904398025977193\" data-ad-slot=\"4723729075\" data-color-link=\"2244BB\" qgdsrhu=\"\" hidden=\"\"></ins>\n\n"
+ "<script>\n"
+ "(adsbygoogle = window.adsbygoogle || []).push({});\n"
+ "</script></div>\n"
+ "</div>\n\n\n"
+ "<img src=\"http://static.teleman.pl/images/pixel.gif?show,753804,20160812\" alt=\"\" width=\"0\" height=\"0\" hidden=\"\" style=\"display: none !important;\">\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}