# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:class|className)=(?:[\"']\W+\s*(?:\w+)\()?[\"']([^'\"]+)['\"]"
test_str = ("<div id=\"content\" class=\"container\">\n\n"
"<div style=\"overflow:hidden;margin-top:30px\">\n"
" <div style=\"width:300px;height:250px;float:left\">\n"
"<ins class=\"adsbygoogle turbo\" style=\"display:inline-block !important;width:300px;min-height:250px; display: none !important;\" data-ad-client=\"ca-pub-1904398025977193\" data-ad-slot=\"4723729075\" data-color-link=\"2244BB\" qgdsrhu=\"\" hidden=\"\"></ins>\n\n"
"<script>\n"
"(adsbygoogle = window.adsbygoogle || []).push({});\n"
"</script></div>\n"
"</div>\n\n\n"
"<img src=\"http://static.teleman.pl/images/pixel.gif?show,753804,20160812\" alt=\"\" width=\"0\" height=\"0\" hidden=\"\" style=\"display: none !important;\">\n"
"</div>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.