// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)(?:class|className)=(?:["']\W+\s*(?:\w+)\()?["']([^'"]+)['"]"#).unwrap();
let string = "<div id=\"content\" class=\"container\">
<div style=\"overflow:hidden;margin-top:30px\">
<div style=\"width:300px;height:250px;float:left\">
<ins class=\"adsbygoogle turbo\" style=\"display:inline-block !important;width:300px;min-height:250px; display: none !important;\" data-ad-client=\"ca-pub-1904398025977193\" data-ad-slot=\"4723729075\" data-color-link=\"2244BB\" qgdsrhu=\"\" hidden=\"\"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
<img src=\"http://static.teleman.pl/images/pixel.gif?show,753804,20160812\" alt=\"\" width=\"0\" height=\"0\" hidden=\"\" style=\"display: none !important;\">
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}