using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|;)(id|cat):|\G(?!^),?([^,;]+)";
string input = @"cat:others;id:4,9,13;id:4,9,13;cat:electric-products;id:4,9,13;cat:foods;cat:drinks,foods";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}