const regex = /(?:^|;)(id|cat):|\G(?!^),?([^,;]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|;)(id|cat):|\\G(?!^),?([^,;]+)', 'gm')
const str = `cat:others;id:4,9,13;id:4,9,13;cat:electric-products;id:4,9,13;cat:foods;cat:drinks,foods`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}