re = /(?:^|;)(id|cat):|\G(?!^),?([^,;]+)/m
str = 'cat:others;id:4,9,13;id:4,9,13;cat:electric-products;id:4,9,13;cat:foods;cat:drinks,foods'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end