# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=(?:\b[01]\d|2[0-3]):[0-5]\d\b)/\n/gm;t' <<< "Received from SOMEONE 11/02/2020 13:20 $ 997,63 $ 997,63 -
"