import Foundation
let pattern = #"(?=(?:\b[01]\d|2[0-3]):[0-5]\d\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Received from SOMEONE 11/02/2020 13:20 $ 997,63 $ 997,63 -
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)