using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?:\b[01]\d|2[0-3]):[0-5]\d\b)";
string substitution = @"\n";
string input = @"Received from SOMEONE 11/02/2020 13:20 $ 997,63 $ 997,63 -
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}