# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=(?:\b[01]\d|2[0-3]):[0-5]\d\b)"
test_str = ("Received from SOMEONE 11/02/2020 13:20 $ 997,63 $ 997,63 -\n")
subst = "\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.