using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"^(([[a-zA-Z\p{L}\.\-']{1,30})(\s))(([a-zA-Z\p{L}\.\-']{1,30})(\s))?([[a-zA-Z\p{L}\.\-']{1,30})(\s)?(\([a-zA-Z\p{L}\.\-'\s]{1,50}\))?$";
        string input = @"Robert Alvarez
Yvonne Andersen
Bob Anderson (director)
Mike B. Anderson
Stephen Anderson (artist)
Joel Zwick
Terry Zwigoff
Andrzej Żuławski
Xawery Żuławski
Harald Zwart
Ezz El-Dine Zulficar (potate)
Irvin S. Yeaworth Jr.
";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}