using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"hide_this\d+";
string input = @"hide_this364526452 hide_this0090890
hide_this
214346546
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}