re = /hide_this\d+/m
str = 'hide_this364526452 hide_this0090890
hide_this
214346546
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end