$re = '/hide_this\d+/m';
$str = 'hide_this364526452 hide_this0090890
hide_this
214346546
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);