const regex = /hide_this\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('hide_this\\d+', 'gm')
const str = `hide_this364526452 hide_this0090890
hide_this
214346546
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}