const regex = new RegExp('^[^|]*', 'gm')
const str = `2022-04-14 17:16:45.896 | ERROR | app.services.xxx.services:eosd:38 - (<class 'KeyError'>, KeyError('data'), <traceback object at 0x75b968f5c180>)
Traceback (most recent call last):
File "/env/bin/uvicorn", line 8, in <module>
sys.exit(main())
│ │ └ <Command main>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}