re = /^[^|]*/m
str = '2022-04-14 17:16:45.896 | ERROR | app.services.xxx.services:eosd:38 - (<class \'KeyError\'>, KeyError(\'data\'), <traceback object at 0x75b968f5c180>)
Traceback (most recent call last):
File "/env/bin/uvicorn", line 8, in <module>
sys.exit(main())
│ │ └ <Command main>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end