use strict;
my $str = '2022-04-14 17:16:45.896 | ERROR | app.services.xxx.services:eosd:38 - (<class \'KeyError\'>, KeyError(\'data\'), <traceback object at 0x75b968f5c180>)
Traceback (most recent call last):
File "/env/bin/uvicorn", line 8, in <module>
sys.exit(main())
│ │ └ <Command main>';
my $regex = qr/^[^|]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}