// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^|]*").unwrap();
let string = "2022-04-14 17:16:45.896 | ERROR | app.services.xxx.services:eosd:38 - (<class 'KeyError'>, KeyError('data'), <traceback object at 0x75b968f5c180>)
Traceback (most recent call last):
File \"/env/bin/uvicorn\", line 8, in <module>
sys.exit(main())
│ │ └ <Command main>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}