#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i).*,"
Local $sString = "The concept arose in the 1950s, when the American mathematician Stephen Cole Kleene formalized the description of a regular language, and came into common use with Unix text-processing utilities. Today different syntaxes for writing regular expressions exist, one being the POSIX standard, another widely used being the Perl syntax."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")