import Foundation
let pattern = #".*,"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"The concept arose in the 1950s, when the American mathematician Stephen Cole Kleene formalized the description of a regular language, and came into common use with Unix text-processing utilities. Today different syntaxes for writing regular expressions exist, one being the POSIX standard, another widely used being the Perl syntax."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)