using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*,";
string input = @"The concept arose in the 1950s, when the American mathematician Stephen Cole Kleene formalized the description of a regular language, and came into common use with Unix text-processing utilities. Today different syntaxes for writing regular expressions exist, one being the POSIX standard, another widely used being the Perl syntax.";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}