using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<Field(?:Array)?\b(?=[^\/>]+name=""document"")[^>]+\/>";
string input = @"<Field
name=""amount""
component={FormField}
label={t('form.amount')}
/>
<Field
name=""datereception""
component={FormField}
label={t('form.datereception')}
/>
<Field
component={FormField}
name=""document""
typeInput=""selectAutocomplete""
/>
<Field
name=""datedeferred""
component={FormField}
label={t('form.datedeferred')}
/>
<FieldArray
component={FormField}
typeInput=""selectAutocomplete""
name=""document""
/><FieldArray
component={FormField}
typeInput=""selectAutocomplete""
name=""document""
/>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}