import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<Field(?:Array)?\\b(?=[^\\/>]+name=\"document\")[^>]+\\/>";
final String string = "<Field\n"
+ " name=\"amount\"\n"
+ " component={FormField}\n"
+ " label={t('form.amount')}\n"
+ " />\n"
+ " <Field\n"
+ " name=\"datereception\"\n"
+ " component={FormField}\n"
+ " label={t('form.datereception')}\n"
+ " />\n"
+ " <Field\n"
+ " component={FormField}\n"
+ " name=\"document\"\n"
+ " typeInput=\"selectAutocomplete\"\n"
+ " />\n"
+ " <Field\n"
+ " name=\"datedeferred\"\n"
+ " component={FormField}\n"
+ " label={t('form.datedeferred')}\n"
+ " />\n"
+ "<FieldArray\n"
+ " component={FormField}\n"
+ " typeInput=\"selectAutocomplete\"\n"
+ " name=\"document\"\n"
+ " /><FieldArray\n"
+ " component={FormField}\n"
+ " typeInput=\"selectAutocomplete\"\n"
+ " name=\"document\"\n"
+ " />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}