import re
regex = re.compile(r"<Field(?:Array)?\b(?=[^\/>]+name=\"document\")[^>]+\/>")
test_str = ("<Field\n"
" name=\"amount\"\n"
" component={FormField}\n"
" label={t('form.amount')}\n"
" />\n"
" <Field\n"
" name=\"datereception\"\n"
" component={FormField}\n"
" label={t('form.datereception')}\n"
" />\n"
" <Field\n"
" component={FormField}\n"
" name=\"document\"\n"
" typeInput=\"selectAutocomplete\"\n"
" />\n"
" <Field\n"
" name=\"datedeferred\"\n"
" component={FormField}\n"
" label={t('form.datedeferred')}\n"
" />\n"
"<FieldArray\n"
" component={FormField}\n"
" typeInput=\"selectAutocomplete\"\n"
" name=\"document\"\n"
" /><FieldArray\n"
" component={FormField}\n"
" typeInput=\"selectAutocomplete\"\n"
" name=\"document\"\n"
" />")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")