re = /<Field(?:Array)?\b(?=[^\/>]+name="document")[^>]+\/>/
str = '<Field
name="amount"
component={FormField}
label={t(\'form.amount\')}
/>
<Field
name="datereception"
component={FormField}
label={t(\'form.datereception\')}
/>
<Field
component={FormField}
name="document"
typeInput="selectAutocomplete"
/>
<Field
name="datedeferred"
component={FormField}
label={t(\'form.datedeferred\')}
/>
<FieldArray
component={FormField}
typeInput="selectAutocomplete"
name="document"
/><FieldArray
component={FormField}
typeInput="selectAutocomplete"
name="document"
/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end