import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:GET|HEAD):.*?application\\/(?:activity|ld)\\+json";
final String string = "======================================================\n"
+ "Basic testing with \"just\" the expexted pattern\n"
+ "======================================================\n\n"
+ "GET:application/activity+json\n"
+ "GET:application/activity+xml\n"
+ "HEAD:application/activity+json\n"
+ "POST:application/activity+json\n\n"
+ "GET:application/ld+json\n"
+ "GET:application/ld+xml\n"
+ "HEAD:application/ld+json\n"
+ "POST:application/ld+json\n\n"
+ "======================================================\n"
+ "Testing with additional suffix in the header\n"
+ "======================================================\n\n"
+ "GET:application/activity+json,something,else\n"
+ "GET:application/activity+xml,something,else\n"
+ "HEAD:application/activity+json,something,else\n"
+ "POST:application/activity+json,something,else\n\n"
+ "GET:application/ld+json,something,else\n"
+ "GET:application/ld+xml,something,else\n"
+ "HEAD:application/ld+json,something,else\n"
+ "POST:application/ld+json,something,else\n\n"
+ "======================================================\n"
+ "Testing with additional prefix *and* suffix in the header\n"
+ "======================================================\n\n"
+ "GET:something before, application/activity+json, something, after\n"
+ "GET:something before, application/activity+xml, something, after\n"
+ "HEAD:something before, application/activity+json, something, after\n"
+ "POST:something before, application/activity+json, something, after\n\n"
+ "GET:something before, application/ld+json, something, after\n"
+ "GET:something before, application/ld+xml, something, after\n"
+ "HEAD:something before, application/ld+json, something, after\n"
+ "POST:something before, application/ld+json, something, after";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}