use strict;
my $str = '======================================================
Basic testing with "just" the expexted pattern
======================================================
GET:application/activity+json
GET:application/activity+xml
HEAD:application/activity+json
POST:application/activity+json
GET:application/ld+json
GET:application/ld+xml
HEAD:application/ld+json
POST:application/ld+json
======================================================
Testing with additional suffix in the header
======================================================
GET:application/activity+json,something,else
GET:application/activity+xml,something,else
HEAD:application/activity+json,something,else
POST:application/activity+json,something,else
GET:application/ld+json,something,else
GET:application/ld+xml,something,else
HEAD:application/ld+json,something,else
POST:application/ld+json,something,else
======================================================
Testing with additional prefix *and* suffix in the header
======================================================
GET:something before, application/activity+json, something, after
GET:something before, application/activity+xml, something, after
HEAD:something before, application/activity+json, something, after
POST:something before, application/activity+json, something, after
GET:something before, application/ld+json, something, after
GET:something before, application/ld+xml, something, after
HEAD:something before, application/ld+json, something, after
POST:something before, application/ld+json, something, after';
my $regex = qr/^(?:GET|HEAD):.*?application\/(?:activity|ld)\+json/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}