// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:GET|HEAD):.*?application\/(?:activity|ld)\+json").unwrap();
let string = "======================================================
Basic testing with \"just\" the expexted pattern
======================================================
GET:application/activity+json
GET:application/activity+xml
HEAD:application/activity+json
POST:application/activity+json
GET:application/ld+json
GET:application/ld+xml
HEAD:application/ld+json
POST:application/ld+json
======================================================
Testing with additional suffix in the header
======================================================
GET:application/activity+json,something,else
GET:application/activity+xml,something,else
HEAD:application/activity+json,something,else
POST:application/activity+json,something,else
GET:application/ld+json,something,else
GET:application/ld+xml,something,else
HEAD:application/ld+json,something,else
POST:application/ld+json,something,else
======================================================
Testing with additional prefix *and* suffix in the header
======================================================
GET:something before, application/activity+json, something, after
GET:something before, application/activity+xml, something, after
HEAD:something before, application/activity+json, something, after
POST:something before, application/activity+json, something, after
GET:something before, application/ld+json, something, after
GET:something before, application/ld+xml, something, after
HEAD:something before, application/ld+json, something, after
POST:something before, application/ld+json, something, after";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}