import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(*SKIP)(?:\\.\\d+)?(?=\\s*руб\\.)";
final String string = "Бронирование № 372 12343.22 от 24 июня 21. Стоимость проживания 1000.32 руб. а так же комиссия в размере 500 руб.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}