re = /\d+(*SKIP)(?:\.\d+)?(?=\s*руб\.)/
str = 'Бронирование № 372 12343.22 от 24 июня 21. Стоимость проживания 1000.32 руб. а так же комиссия в размере 500 руб.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end