import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([Aa]cestream:\\/\\/|http:\\/\\/127\\.0\\.0\\.1:6878\\/ace.*\\?.*=)([a-z,0-9]{40})";
final String string = "acestream://4b9a3382d30af6588d484e92377629ce3b6a32da\n"
+ "acestream://4a3286ad2718d35a55bfb81da22c5d04aad42e29\n"
+ "http://127.0.0.1:6878/ace/getstream?infohash=01670d76bdc01781c122695b96093b4cbfdacc3b";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}