$re = '/([Aa]cestream:\/\/|http:\/\/127\.0\.0\.1:6878\/ace.*\?.*=)([a-z,0-9]{40})/m';
$str = 'acestream://4b9a3382d30af6588d484e92377629ce3b6a32da
acestream://4a3286ad2718d35a55bfb81da22c5d04aad42e29
http://127.0.0.1:6878/ace/getstream?infohash=01670d76bdc01781c122695b96093b4cbfdacc3b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);