import re
regex = re.compile(r"([Aa]cestream:\/\/|http:\/\/127\.0\.0\.1:6878\/ace.*\?.*=)([a-z,0-9]{40})", flags=re.MULTILINE)
test_str = ("acestream://4b9a3382d30af6588d484e92377629ce3b6a32da\n"
"acestream://4a3286ad2718d35a55bfb81da22c5d04aad42e29\n"
"http://127.0.0.1:6878/ace/getstream?infohash=01670d76bdc01781c122695b96093b4cbfdacc3b")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")