using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1000\d{11}";
string input = @"100012345678912
1000123456789121
1000123456789121000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}