$re = '/1000\d{11}/m';
$str = '100012345678912
1000123456789121
1000123456789121000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);