const regex = /1000\d{11}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('1000\\d{11}', 'gm')
const str = `100012345678912
1000123456789121
1000123456789121000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}