package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)1000\d{11}`)
var str = `100012345678912
1000123456789121
1000123456789121000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}