using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"getopt(?:s|)(?: (?:-[a-zA-Z])*)*(?'name'[$a-zA-Z]+|)\s(?:(?:-o|--options) (?'short'.+) (?:-l|--longoptions|--long) (?'long'(?:[a-zA-Z0-9]|,|:|\$)+) \-\- \""\$@\""|(?:(?:(?:-[a-zA-Z])*|)\s*\""(?'while'(?:[a-zA-Z0-9]|,|:|\$)+)\""))";
string input = @"while getopts -a "":n:t:"" options; do
while getopts -a -n "":n:t:"" options; do
while getopt "":n:t:"" options; do
Parameters=$(getopt -a -n $ScriptName --options $SHORT --longoptions $LONG -- ""$@"")
Parameters=$(getopt -a -n alphabet -o abc:d: --long alpha,bravo,charlie:,delta: -- ""$@"")";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}